summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/guessit/guessit-3.0.0.ebuild')
-rw-r--r--dev-python/guessit/guessit-3.0.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/guessit/guessit-3.0.0.ebuild b/dev-python/guessit/guessit-3.0.0.ebuild
deleted file mode 100644
index a1fbba8fd954..000000000000
--- a/dev-python/guessit/guessit-3.0.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for guessing information from video filenames"
-HOMEPAGE="https://github.com/guessit-io/guessit https://pypi.org/project/guessit/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
- >=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable benchmarks as they require unavailable pytest-benchmark.
- rm guessit/test/test_benchmark.py || die
- sed -i -e "s|'pytest-benchmark',||g" setup.py || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
- distutils-r1_python_prepare_all
-}