summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h5py/h5py-2.6.0.ebuild')
-rw-r--r--dev-python/h5py/h5py-2.6.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/h5py/h5py-2.6.0.ebuild b/dev-python/h5py/h5py-2.6.0.ebuild
deleted file mode 100644
index 5f9126c24ce1..000000000000
--- a/dev-python/h5py/h5py-2.6.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="http://www.h5py.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test examples mpi"
-
-RDEPEND="
- sci-libs/hdf5:=[mpi=,hl(+)]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/alabaster[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
- )
- mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
-
-pkg_setup() {
- use mpi && export CC=mpicc
-}
-
-python_prepare_all() {
- append-cflags -fno-strict-aliasing
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- esetup.py configure $(usex mpi --mpi '')
-}
-
-python_compile_all() {
- if use doc; then
- cd "${S}"/docs || die
- sed '/html_theme/s:default:alabaster:g' -i conf.py || die
- emake html
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- DOCS=( README.rst ANN.rst )
- use doc && HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}