summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hatchling/hatchling-1.15.0.ebuild')
-rw-r--r--dev-python/hatchling/hatchling-1.15.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/hatchling/hatchling-1.15.0.ebuild b/dev-python/hatchling/hatchling-1.15.0.ebuild
index d19c9d5239f8..a71cd5b7faf4 100644
--- a/dev-python/hatchling/hatchling-1.15.0.ebuild
+++ b/dev-python/hatchling/hatchling-1.15.0.ebuild
@@ -69,11 +69,16 @@ python_test() {
tests/backend/dep/test_core.py::test_extra_unmet
tests/backend/dep/test_core.py::test_unknown_extra
tests/backend/dep/test_core.py::test_version_unmet
+ # broken if CARGO is set
+ tests/backend/builders/test_app.py::TestBuildBootstrap::test_no_cargo
)
# top-level "tests" directory contains tests both for hatch
# and hatchling
cd "${WORKDIR}/${MY_P}" || die
local -x PYTHONPATH="src:${PYTHONPATH}"
+ # tests mock cargo subprocess call but the backend raises if CARGO
+ # is not set and shutil.which() can't find it
+ local -x CARGO=cargo
epytest tests/backend
}