summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest2
-rw-r--r--dev-python/httplib2/httplib2-0.22.0.ebuild (renamed from dev-python/httplib2/httplib2-0.19.1.ebuild)40
2 files changed, 31 insertions, 11 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index 2cee1e7e3ce7..f6cbc21cab80 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1 +1 @@
-DIST httplib2-0.19.1.tar.gz 263971 BLAKE2B ec254249f5c8df2a0dc3fe4e2e9088f6ca14ba84516be77450beacab41cd295d4e741ac6026471fcf8bb8464ebd732a0a856901e5c09324a0f96ad2338b397e7 SHA512 0c87b3c9923e81c83df5257ce60f7248d86a64aea0a02d5a3f34be68c692c6abd896f95214899dc6e81b23677efc7684a3cba4c1a47261176dd26c3988054e55
+DIST httplib2-0.22.0.gh.tar.gz 373972 BLAKE2B 6adfbc61d4f898666512da5d02cf082fcaf76bf1816de955510f5c4721a36c38d99fef963d5150b62cca091543ed65bb1ef5f33ce99123e1cd2abe467d4970e3 SHA512 77210f85ccaa2d2cf4a6c89f5146ca5eb9a6f26f00e862f6d0716ec73baffdf94714ae1d5eaced4349920b91276a7835e2f028c6d9156e84c241514b198791e5
diff --git a/dev-python/httplib2/httplib2-0.19.1.ebuild b/dev-python/httplib2/httplib2-0.22.0.ebuild
index 04e2897eb136..ed1ee5aad216 100644
--- a/dev-python/httplib2/httplib2-0.19.1.ebuild
+++ b/dev-python/httplib2/httplib2-0.22.0.ebuild
@@ -1,27 +1,38 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="https://pypi.org/project/httplib2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://pypi.org/project/httplib2/
+ https://github.com/httplib2/httplib2/
+"
+SRC_URI="
+ https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
RDEPEND="
app-misc/ca-certificates
- dev-python/pyparsing[${PYTHON_USEDEP}]"
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
+ dev-libs/openssl
dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
@@ -29,11 +40,13 @@ PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
src_prepare() {
sed -i -e '/--cov/d' setup.cfg || die
+ # cryptography dep is entirely optional, and has a good fallback
+ sed -i -e 's:from cryptography.*:pass:' tests/__init__.py || die
distutils-r1_src_prepare
}
python_test() {
- local deselect=(
+ local EPYTEST_DESELECT=(
# broken by using system certificates
tests/test_cacerts_from_env.py::test_certs_file_from_builtin
tests/test_cacerts_from_env.py::test_certs_file_from_environment
@@ -42,9 +55,16 @@ python_test() {
# broken by new PySocks, probably
tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
tests/test_proxy.py::test_socks5_auth
+
+ # broken by recerting (TODO)
+ tests/test_https.py::test_min_tls_version
+ tests/test_https.py::test_max_tls_version
+
+ # new cryptography or openssl-3?
+ tests/test_https.py::test_client_cert_password_verified
)
# tests in python* are replaced by tests/
# upstream fails at cleaning up stuff
- epytest ${deselect[@]/#/--deselect } tests
+ epytest tests
}