summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanfriendly/humanfriendly-9.2.ebuild')
-rw-r--r--dev-python/humanfriendly/humanfriendly-9.2.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-9.2.ebuild b/dev-python/humanfriendly/humanfriendly-9.2.ebuild
deleted file mode 100644
index e7c4b6fdf3fc..000000000000
--- a/dev-python/humanfriendly/humanfriendly-9.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Human friendly output for text interfaces using Python"
-HOMEPAGE="https://pypi.org/project/humanfriendly/
- https://github.com/xolox/python-humanfriendly/
- https://humanfriendly.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- dev-python/capturer[${PYTHON_USEDEP}]
- >=dev-python/coloredlogs-15.0.1[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_test() {
- epytest humanfriendly/tests.py
-}