summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest4
-rw-r--r--dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild (renamed from dev-python/humanfriendly/humanfriendly-9.2.ebuild)17
-rw-r--r--dev-python/humanfriendly/humanfriendly-8.2.ebuild37
-rw-r--r--dev-python/humanfriendly/humanfriendly-9.1.ebuild36
-rw-r--r--dev-python/humanfriendly/metadata.xml2
5 files changed, 12 insertions, 84 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 239b104a0b72..eb2f81777ec1 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,3 +1 @@
-DIST humanfriendly-8.2.tar.gz 358747 BLAKE2B bc5824e94ea94df6ee93ea44d273ccb856f50b69e52ae6293afaedf06c9f00c67e064f0c85edd88be9954bb258334b1b9af4ab88efc5b352f3efe8d322fc55c1 SHA512 123d8592e6613a70421740648bb8998733b118927a0bd6182af848612e46eec8e35cae95168219c9b7672bed8e18e1c4a493a80248eabe47f8a4cb1813c8b591
-DIST humanfriendly-9.1.tar.gz 359616 BLAKE2B c67ca9498ff4a0dac237c8f1c81ae88882a7ab162e2cfd663cd50a066dbcfe045424bdf4dcc1df473f5fc41f0c1b8c0f2aca9883aa21915281618ba332c579a3 SHA512 859a9ff01abe0671a23a63e73c9c09c0f92151e96ec38dd5695c75f99fa436e186835cb8a16f59b82d5216b9c427ea0abd419b470b067f8032fe984776f02a8f
-DIST humanfriendly-9.2.tar.gz 360080 BLAKE2B 39aa17315a87938468f2d6e94b0287f07864476c4179c40504126c65f7042c96113a9d60f481a6a03913ae5c8cfde2c87476e0d403c964aa65abceb0f55633f1 SHA512 2abb8d7d4dfb84d625e82f3475bea5045c32f548a45999dca97d39e5bc0cd704a9ab45e0b6b87c0d419b447680a3e71e2d9c8cb14ba19117c7ac9b2f56297f00
+DIST humanfriendly-10.0.tar.gz 360702 BLAKE2B 6db7f2f11bafcdc087c078eae6123046610594b17899678e445baa18c25b2210cc1d84363d858ab7c57fce6d6b7a189be69dea08c1891d3f5b11ff9900c9bef9 SHA512 496700bcea1dabf003c938558bf807fabb41b71192f69622979dd9e243dda9b4b06c5ac8f65cef217df85ebadf99099dc22b50d63216791a569be11081d267d6
diff --git a/dev-python/humanfriendly/humanfriendly-9.2.ebuild b/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild
index e7c4b6fdf3fc..b0c40d48af3b 100644
--- a/dev-python/humanfriendly/humanfriendly-9.2.ebuild
+++ b/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild
@@ -1,22 +1,25 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{8..9} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
DESCRIPTION="Human friendly output for text interfaces using Python"
HOMEPAGE="https://pypi.org/project/humanfriendly/
https://github.com/xolox/python-humanfriendly/
https://humanfriendly.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+# This is completely broken
+# AttributeError: module 'humanfriendly.tests' has no attribute 'connect'
+RESTRICT="test"
BDEPEND="
test? (
diff --git a/dev-python/humanfriendly/humanfriendly-8.2.ebuild b/dev-python/humanfriendly/humanfriendly-8.2.ebuild
deleted file mode 100644
index 03462a33c378..000000000000
--- a/dev-python/humanfriendly/humanfriendly-8.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Human friendly output for text interfaces using Python"
-HOMEPAGE="https://pypi.org/project/humanfriendly/
- https://github.com/xolox/python-humanfriendly/
- https://humanfriendly.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- dev-python/capturer[${PYTHON_USEDEP}]
- dev-python/coloredlogs[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_test() {
- pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/humanfriendly/humanfriendly-9.1.ebuild b/dev-python/humanfriendly/humanfriendly-9.1.ebuild
deleted file mode 100644
index 9ba2dcee001c..000000000000
--- a/dev-python/humanfriendly/humanfriendly-9.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Human friendly output for text interfaces using Python"
-HOMEPAGE="https://pypi.org/project/humanfriendly/
- https://github.com/xolox/python-humanfriendly/
- https://humanfriendly.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- test? (
- dev-python/capturer[${PYTHON_USEDEP}]
- dev-python/coloredlogs[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_test() {
- pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/humanfriendly/metadata.xml b/dev-python/humanfriendly/metadata.xml
index 16360517e2a3..1ed7becbc774 100644
--- a/dev-python/humanfriendly/metadata.xml
+++ b/dev-python/humanfriendly/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>