summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanize/humanize-3.12.0-r1.ebuild')
-rw-r--r--dev-python/humanize/humanize-3.12.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-3.12.0-r1.ebuild b/dev-python/humanize/humanize-3.12.0-r1.ebuild
new file mode 100644
index 000000000000..e01d205acf43
--- /dev/null
+++ b/dev-python/humanize/humanize-3.12.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ sed -e '/setuptools/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}