summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest5
-rw-r--r--dev-python/hypothesis/hypothesis-6.102.1.ebuild (renamed from dev-python/hypothesis/hypothesis-6.54.5.ebuild)33
-rw-r--r--dev-python/hypothesis/hypothesis-6.102.6.ebuild (renamed from dev-python/hypothesis/hypothesis-6.54.6.ebuild)31
-rw-r--r--dev-python/hypothesis/hypothesis-6.55.0.ebuild76
-rw-r--r--dev-python/hypothesis/metadata.xml9
5 files changed, 49 insertions, 105 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index b97448364e34..cc371f507703 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,2 @@
-DIST hypothesis-6.54.5.gh.tar.gz 9325448 BLAKE2B b4cb8a413ad96f11f4dbf4a1a529e389dbca45561264cf0922721a25009d1065fdce21064faf53bd7aad2f589c159b52d899aa7b12c12da68beae8c9186c0505 SHA512 37205ea28b44537409a94592e466376e9612f84a8501ad2ff5504fc648e062555ffb600416bdd1f9a74f39ba39729defd581025e0611c501839721721f7cf6e3
-DIST hypothesis-6.54.6.gh.tar.gz 9325898 BLAKE2B 01dde1d57192ede0a732ba2a50954fb6b1a1532e584715186f813977b2f22fd3411ec489874da67e687ca470ac58340dc45b821923ab01b03888c44a7882c0c0 SHA512 d678d0936c7906c839c29ad6c08154a067f8be2e18344139051ecc4b5c737f5088d2775a25758da2e29b74574b47c5f817643ccb762db851bc2b25e4fdbb3259
-DIST hypothesis-6.55.0.gh.tar.gz 9330281 BLAKE2B 63f967496ed96e945579390d20eefb4d533caac80a05dc2fb3aa82bcca232d629802a9a37c73eb5ca8685530021794a1d0507e86fda90714be4de863ac20bcdb SHA512 2c013b2c8cd4682e1c6ef61dff63ee14d0f306815e83165cbb25dff2d5f5cf456a1567c8df669497f2e3d981222da9eba4ea94fc9b88519045ac458249ff6e0d
+DIST hypothesis-6.102.1.gh.tar.gz 9459939 BLAKE2B 36edbaf4ad89af3c4554e05ed395b29681b39708cd85a35cd5662766ce08ac95564a2b7ff7892e98df3fad1e729b779d00fcce86c2d17b879a21f3c877156875 SHA512 acb2b5f62e9f23eb379d61705f22330d9e81f7a23164bbdd196124fc3a67ba1265125597f840fa135f35af6f626229b3340b9557b2d69fc81f0b08c99d948e18
+DIST hypothesis-6.102.6.gh.tar.gz 9462342 BLAKE2B 7daf1cfedd3e8aec72ca2a16a320ccac8c03d62dd02c7b6e20a8c0e8e9510996fc36b5f1050c111ef2eb389b77a9f468b23ef7627867b8d50559c59df003f635 SHA512 aa458c9db8ca0f5661ffc64ae61b08ffe2e93cd1fe5431752aa92339af22cf90b79763d08c6e381dd0875b26b2cfbdad92e95cc581ba325072ec5330223d3b7e
diff --git a/dev-python/hypothesis/hypothesis-6.54.5.ebuild b/dev-python/hypothesis/hypothesis-6.102.1.ebuild
index 0eb4bd6ad325..ae8fc1c6021e 100644
--- a/dev-python/hypothesis/hypothesis-6.54.5.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.102.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 python3_13 )
PYTHON_REQ_USE="threads(+),sqlite"
inherit distutils-r1 multiprocessing optfeature
@@ -25,15 +25,15 @@ S="${WORKDIR}/${MY_P}/hypothesis-python"
LICENSE="MPL-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="cli"
RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
+ ' 3.9 3.10)
cli? (
$(python_gen_cond_dep '
dev-python/black[${PYTHON_USEDEP}]
@@ -43,9 +43,10 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
)
"
@@ -54,9 +55,23 @@ distutils_enable_tests pytest
python_test() {
# subtests are broken by warnings from random plugins
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
- epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
}
python_install() {
diff --git a/dev-python/hypothesis/hypothesis-6.54.6.ebuild b/dev-python/hypothesis/hypothesis-6.102.6.ebuild
index 51ed1bc82c36..c2bf166b155f 100644
--- a/dev-python/hypothesis/hypothesis-6.54.6.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.102.6.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 python3_13 )
PYTHON_REQ_USE="threads(+),sqlite"
inherit distutils-r1 multiprocessing optfeature
@@ -29,11 +29,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~
IUSE="cli"
RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
+ ' 3.9 3.10)
cli? (
$(python_gen_cond_dep '
dev-python/black[${PYTHON_USEDEP}]
@@ -43,9 +43,10 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
)
"
@@ -54,9 +55,23 @@ distutils_enable_tests pytest
python_test() {
# subtests are broken by warnings from random plugins
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
- epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
}
python_install() {
diff --git a/dev-python/hypothesis/hypothesis-6.55.0.ebuild b/dev-python/hypothesis/hypothesis-6.55.0.ebuild
deleted file mode 100644
index 51ed1bc82c36..000000000000
--- a/dev-python/hypothesis/hypothesis-6.55.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 multiprocessing optfeature
-
-TAG=hypothesis-python-${PV}
-MY_P=hypothesis-${TAG}
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="
- https://github.com/HypothesisWorks/hypothesis/
- https://pypi.org/project/hypothesis/
-"
-SRC_URI="
- https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${MY_P}/hypothesis-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="cli"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- cli? (
- $(python_gen_cond_dep '
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- ' "${CLI_COMPAT[@]}")
- )
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # subtests are broken by warnings from random plugins
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
-
- epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
-}
-
-python_install() {
- distutils-r1_python_install
- if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
- rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
- fi
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}
diff --git a/dev-python/hypothesis/metadata.xml b/dev-python/hypothesis/metadata.xml
index c68c89a4f8bc..91343edcb81f 100644
--- a/dev-python/hypothesis/metadata.xml
+++ b/dev-python/hypothesis/metadata.xml
@@ -1,15 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!--
- This package has a very frequent release cycle which makes
- it hard to track stable candidates. Please do not bump it
- without my approval.
- -->
- <maintainer type="person">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
<maintainer type="project">
<email>python@gentoo.org</email>
<name>Python</name>