summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest5
-rw-r--r--dev-python/identify/identify-2.2.13.ebuild19
-rw-r--r--dev-python/identify/identify-2.2.14.ebuild19
-rw-r--r--dev-python/identify/identify-2.2.15.ebuild19
-rw-r--r--dev-python/identify/identify-2.5.35.ebuild29
-rw-r--r--dev-python/identify/identify-2.5.36.ebuild29
-rw-r--r--dev-python/identify/metadata.xml1
7 files changed, 61 insertions, 60 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 9e8b4e20bcfe..4dcb1833269f 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,3 +1,2 @@
-DIST identify-2.2.13.tar.gz 101136 BLAKE2B b1835ca6b576a15be16de124554cfaf7b6dc55a1dfee70021613d35251135c295c3acf141eb645823add4c260bec9fdcde4799f0b72fbd57bc7a2e8659e416bd SHA512 37764325268c164028b7719f91571c006c9c6db3f4bba5a93d20f3d9ea30712cfe7e5710b175266a3d74f3f85485f16ebf7d21486d4329050b55e5835e8b4197
-DIST identify-2.2.14.tar.gz 101144 BLAKE2B 9a23595173ab2ebfcbbcfc503e9750ef1e9c0c068e9d1a1b2f47dd2e08787f734541a79ae65b4a72a7de076b8f7ab4f877f3bb049560f33b38698729b9d5f3ab SHA512 9dc27e745f30fc1e6ee5135cdb82de004a5c60f17c47ab3e1deffe1c3c04adc47211bde161216be202db2171711a7dfea5f0ba60a56fea0cbc75ec6d55c6203f
-DIST identify-2.2.15.tar.gz 101146 BLAKE2B 1855598314c191a9e4d2f73c2c7a424957a76177df1daf32b4c7de6ddbda4439fac0860ed105e4a2ca4aef0555843157499e9840cbbccf42cf728aef93b13607 SHA512 5b85c07603381174fb4265ad8fc411645dc0cecb68b3fc9b2afa7111f18eae7cf39d5cf1000eda8ded256f441a4bf05d9ded11f31c9aa80f55efaf2dc6745697
+DIST identify-2.5.35.gh.tar.gz 101691 BLAKE2B 931169744a9126d82b32bd4dea1731f1f4ad209b78d3df9ce490891994194797a7adcaff19400e9856716528f5b3490e05c8e06614c788b089251ef92cd1dd03 SHA512 1d01535f95818533220c06988eb2d9f495c004b41fd197482ab0e3520f81ab2aebce0344dffeb0449423abd6574c21043fa0ad20472b3aaff6cb97986f31fd88
+DIST identify-2.5.36.gh.tar.gz 101732 BLAKE2B c0f7d7f57a757ec828b7def3a0e7e544855bf4eed8f3b612cc35acda34f05379c5267eb33a0110080708c50a838983a6d662130e297f2e0a00382025c58ccf61 SHA512 713ce08bafc076d2724f847c0b051036072d6b8d53c77a0ca011b7ec3af4ec27381de3ef4622235db0791ef4fc449514f78c2ad250d77c055e9fec9dc6f14a57
diff --git a/dev-python/identify/identify-2.2.13.ebuild b/dev-python/identify/identify-2.2.13.ebuild
deleted file mode 100644
index 0310f5673f98..000000000000
--- a/dev-python/identify/identify-2.2.13.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="File identification library for Python"
-HOMEPAGE="https://github.com/pre-commit/identify"
-SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
diff --git a/dev-python/identify/identify-2.2.14.ebuild b/dev-python/identify/identify-2.2.14.ebuild
deleted file mode 100644
index c3b147be85a7..000000000000
--- a/dev-python/identify/identify-2.2.14.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="File identification library for Python"
-HOMEPAGE="https://github.com/pre-commit/identify"
-SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
diff --git a/dev-python/identify/identify-2.2.15.ebuild b/dev-python/identify/identify-2.2.15.ebuild
deleted file mode 100644
index c3b147be85a7..000000000000
--- a/dev-python/identify/identify-2.2.15.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="File identification library for Python"
-HOMEPAGE="https://github.com/pre-commit/identify"
-SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
diff --git a/dev-python/identify/identify-2.5.35.ebuild b/dev-python/identify/identify-2.5.35.ebuild
new file mode 100644
index 000000000000..6d0d4666c11a
--- /dev/null
+++ b/dev-python/identify/identify-2.5.35.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~hppa ~ppc ~ppc64 ~riscv x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/identify/identify-2.5.36.ebuild b/dev-python/identify/identify-2.5.36.ebuild
new file mode 100644
index 000000000000..0aa9daac20bc
--- /dev/null
+++ b/dev-python/identify/identify-2.5.36.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/identify/metadata.xml b/dev-python/identify/metadata.xml
index 4c21ffb197d0..9e1cf7348f8c 100644
--- a/dev-python/identify/metadata.xml
+++ b/dev-python/identify/metadata.xml
@@ -9,6 +9,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">pre-commit/identify</remote-id>
<remote-id type="pypi">identify</remote-id>