summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest2
-rw-r--r--dev-python/imageio/imageio-2.25.0.ebuild82
-rw-r--r--dev-python/imageio/imageio-2.25.1.ebuild82
3 files changed, 0 insertions, 166 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index f7e12bde34b4..7cfb08a63516 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,5 +1,3 @@
-DIST imageio-2.25.0.gh.tar.gz 401690 BLAKE2B 3c7faa7aae06b098a171ad168cd28d14abbc32d519a373ab77c4bec30913faa7baafc2f0b4721a80ee72a6e7b479c12fe27e707c4a90bcaaf2ebceb2b4b39577 SHA512 e887d8572f4698b6cd6fad832054cbce2550a4165e65704c2f990b500234cc938c68b9840bc8961a7258cf4cfa91c3ac909c7965de689b00b04195ab1120850c
-DIST imageio-2.25.1.gh.tar.gz 402105 BLAKE2B 8d7f5881fecf2b5bd5fa0534f4f979db252a1541fce518a4c5acdf7592c8e752dc49e0025d7319fc27588cb457c4f5b05e9a91f510039b95371ac31bee9fd241 SHA512 0473eb10c00e4ceff858394d3bde3b7c42fc7f2c6692ab3f7a1e20c67ab84fed3129948eff5aef0c43bf750906c3b3b8acca75fcbba855b6b9f725258df4241f
DIST imageio-2.26.0.gh.tar.gz 403652 BLAKE2B 2f1948b1cee03ef4fdd71489923a1ea5b0c364fb5f000d79e1d309042184a6bb267a323bd19fce85bf47857245eb4be5283f0b3df65857d7cac57c24930ea409 SHA512 6ad8ce0395033571c0d918dbe03ffeab0e43b29d402bc91a229d3ffd689eae3d01aa09dec386d03fe028f6138887883cfda4e0a769f523ba9f6c3e3041a0cb7f
DIST imageio-chelsea.png 221294 BLAKE2B 58537d7a1678fa5be4cc899e5bacd925bfc180eb4ae691330a53749a49ff544e979609b529ed27e5c1fc9efe4bc050ca1ce49b777f4016fb1d66affd926ef9d3 SHA512 48470cdb843eed4dfa6673811c09c5aac9869ee23dd36be0c6b653d9f108d61d21b148c2a4435aaa6604887ba030e5bbc5e35d378da876366445dfc2d0ba4e27
DIST imageio-cockatoo.mp4 728751 BLAKE2B 45b22cd517c1cb7c0cd12f8865facaca6a847047aea716e49633cf2b1dc13826f94787c8a8f9dd5f48c6a896f5d37794c0058da1bde9e1469f196916476dbfa2 SHA512 e9cb7c25de8019c59ba4090cf10ab29f2b5d62ada37a877081ca07d2ecfe010036222ae843b41bbcc843130d97fa5e14421de252639e9481df1d1c27b19add49
diff --git a/dev-python/imageio/imageio-2.25.0.ebuild b/dev-python/imageio/imageio-2.25.0.ebuild
deleted file mode 100644
index 30875e33909b..000000000000
--- a/dev-python/imageio/imageio-2.25.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-BIN_COMMIT=224074bca448815e421a59266864c23041531a42
-DESCRIPTION="Python library for reading and writing image data"
-HOMEPAGE="
- https://imageio.readthedocs.io/en/stable/
- https://github.com/imageio/imageio/
- https://pypi.org/project/imageio/
-"
-SRC_URI="
- https://github.com/imageio/imageio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/chelsea.png
- -> ${PN}-chelsea.png
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/cockatoo.mp4
- -> ${PN}-cockatoo.mp4
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# over 50% of tests rely on Internet
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
- media-libs/freeimage
-"
-# requests for fsspec[github]
-BDEPEND="
- test? (
- dev-python/fsspec[${PYTHON_USEDEP}]
- dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tifffile[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # block silently downloading vulnerable libraries from the Internet
- "${FILESDIR}"/imageio-2.22.0-block-download.patch
- )
-
- if use test; then
- mkdir -p "${HOME}"/.imageio/images || die
- local i
- for i in chelsea.png cockatoo.mp4; do
- cp "${DISTDIR}/${PN}-${i}" "${HOME}/.imageio/images/${i}" || die
- done
- fi
-
- distutils-r1_src_prepare
-}
-
-EPYTEST_DESELECT=(
- # Fails because of system installed freeimage
- tests/test_core.py::test_findlib2
- # Tries to download ffmpeg binary ?!
- tests/test_ffmpeg.py::test_get_exe_installed
- # blocked by our patch
- tests/test_core.py::test_fetching
- tests/test_core.py::test_request
- # known broken
- # https://github.com/imageio/imageio/issues/890
- tests/test_freeimage.py::test_exr_write
-)
diff --git a/dev-python/imageio/imageio-2.25.1.ebuild b/dev-python/imageio/imageio-2.25.1.ebuild
deleted file mode 100644
index 30875e33909b..000000000000
--- a/dev-python/imageio/imageio-2.25.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-BIN_COMMIT=224074bca448815e421a59266864c23041531a42
-DESCRIPTION="Python library for reading and writing image data"
-HOMEPAGE="
- https://imageio.readthedocs.io/en/stable/
- https://github.com/imageio/imageio/
- https://pypi.org/project/imageio/
-"
-SRC_URI="
- https://github.com/imageio/imageio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/chelsea.png
- -> ${PN}-chelsea.png
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/cockatoo.mp4
- -> ${PN}-cockatoo.mp4
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# over 50% of tests rely on Internet
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
- media-libs/freeimage
-"
-# requests for fsspec[github]
-BDEPEND="
- test? (
- dev-python/fsspec[${PYTHON_USEDEP}]
- dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tifffile[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # block silently downloading vulnerable libraries from the Internet
- "${FILESDIR}"/imageio-2.22.0-block-download.patch
- )
-
- if use test; then
- mkdir -p "${HOME}"/.imageio/images || die
- local i
- for i in chelsea.png cockatoo.mp4; do
- cp "${DISTDIR}/${PN}-${i}" "${HOME}/.imageio/images/${i}" || die
- done
- fi
-
- distutils-r1_src_prepare
-}
-
-EPYTEST_DESELECT=(
- # Fails because of system installed freeimage
- tests/test_core.py::test_findlib2
- # Tries to download ffmpeg binary ?!
- tests/test_ffmpeg.py::test_get_exe_installed
- # blocked by our patch
- tests/test_core.py::test_fetching
- tests/test_core.py::test_request
- # known broken
- # https://github.com/imageio/imageio/issues/890
- tests/test_freeimage.py::test_exr_write
-)