summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imapclient/imapclient-2.1.0.ebuild')
-rw-r--r--dev-python/imapclient/imapclient-2.1.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/imapclient/imapclient-2.1.0.ebuild b/dev-python/imapclient/imapclient-2.1.0.ebuild
deleted file mode 100644
index bca796278b14..000000000000
--- a/dev-python/imapclient/imapclient-2.1.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
-HOMEPAGE="https://github.com/mjs/imapclient"
-SRC_URI="https://github.com/mjs/imapclient/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- # fix incorrect assumption about py3.6 behavior
- # https://github.com/mjs/imapclient/pull/384
- "${FILESDIR}"/imapclient-2.1.0-py36-tests.patch
-)
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS.rst NEWS.rst README.rst )
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}