summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/importlib_resources/importlib_resources-5.2.2.ebuild')
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.2.2.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-5.2.2.ebuild b/dev-python/importlib_resources/importlib_resources-5.2.2.ebuild
deleted file mode 100644
index acad426f3fd6..000000000000
--- a/dev-python/importlib_resources/importlib_resources-5.2.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 python3_8 )
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://github.com/python/importlib_resources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/zipp-3.1.0[${PYTHON_USEDEP}]
- ' pypy3)
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging