summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest3
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.2.2.ebuild29
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.2.3.ebuild29
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.3.0.ebuild29
-rw-r--r--dev-python/importlib_resources/metadata.xml25
5 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
deleted file mode 100644
index 7829363329bf..000000000000
--- a/dev-python/importlib_resources/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST importlib_resources-5.2.2.tar.gz 29651 BLAKE2B dde545a3f104c799432d7a2b6dbea6f071b82d0b6e3660384e2e0ab3c36eee8942b9f248a6139c708020c617bf0e0dce7fbbd5e06cb0bd192a0296fac6350b51 SHA512 7af9aceece4dd25ad827310fde100a4b0b5e0aee03dfeba8789db060e4decafc543784046c2e9eee95d8cab61845c50e4bb0543bb20ae7e1e480aaa80c88fa27
-DIST importlib_resources-5.2.3.tar.gz 30055 BLAKE2B 72d4ff3d5ac974e68063673af980d70644477e4cf7e1c56b0a8b4a69009abbb112867d6527310c2ec37b1a51e343283f8ee153728a1e94654cea7181d0b4f2df SHA512 97c4f99c184d82d198e75240bd262c18ec0496e07e8eeec2451da8c427500859a1b6677ab044d2e36e87f0c4da439757e13d00f8aa9955db17111487594852b6
-DIST importlib_resources-5.3.0.tar.gz 30784 BLAKE2B 876d9bdc1360eecc973f53d6d3397db5708dda1b0f30e5a10d372535f0831cc0fcdcc0b361412df8a1f4453f27315e6547096e14ec7bdbcd1d1af41778d5dd39 SHA512 ad5a0d5b72e8e49a158254d7146411a86bacda3d9019867bad92e8209dd924ae0928dfe46b574967975622d0809d4e1693dab4b6bf8d78867b09cac8c424072c
diff --git a/dev-python/importlib_resources/importlib_resources-5.2.2.ebuild b/dev-python/importlib_resources/importlib_resources-5.2.2.ebuild
deleted file mode 100644
index acad426f3fd6..000000000000
--- a/dev-python/importlib_resources/importlib_resources-5.2.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 python3_8 )
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://github.com/python/importlib_resources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/zipp-3.1.0[${PYTHON_USEDEP}]
- ' pypy3)
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
diff --git a/dev-python/importlib_resources/importlib_resources-5.2.3.ebuild b/dev-python/importlib_resources/importlib_resources-5.2.3.ebuild
deleted file mode 100644
index e844671db232..000000000000
--- a/dev-python/importlib_resources/importlib_resources-5.2.3.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 python3_8 )
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://github.com/python/importlib_resources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/zipp-3.1.0[${PYTHON_USEDEP}]
- ' pypy3)
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
diff --git a/dev-python/importlib_resources/importlib_resources-5.3.0.ebuild b/dev-python/importlib_resources/importlib_resources-5.3.0.ebuild
deleted file mode 100644
index e844671db232..000000000000
--- a/dev-python/importlib_resources/importlib_resources-5.3.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 python3_8 )
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://github.com/python/importlib_resources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/zipp-3.1.0[${PYTHON_USEDEP}]
- ' pypy3)
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
diff --git a/dev-python/importlib_resources/metadata.xml b/dev-python/importlib_resources/metadata.xml
deleted file mode 100644
index cc4d43162e73..000000000000
--- a/dev-python/importlib_resources/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>sbraz@gentoo.org</email>
- <name>Louis Sautier</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <longdescription>
- Backport of Python standard library importlib.resources module
- for Python 2.7, and 3.4 through 3.8. Users of Python 3.9 and beyond
- should use the standard library module, since for these versions,
- importlib_resources just delegates to that module.
- </longdescription>
- <upstream>
- <remote-id type="github">python/importlib_resources</remote-id>
- <remote-id type="pypi">importlib-resources</remote-id>
- <bugs-to>https://github.com/python/importlib_resources/issues</bugs-to>
- <doc>https://importlib-resources.readthedocs.io/</doc>
- </upstream>
-</pkgmetadata>