summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inflection/inflection-0.5.1-r1.ebuild')
-rw-r--r--dev-python/inflection/inflection-0.5.1-r1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/inflection/inflection-0.5.1-r1.ebuild b/dev-python/inflection/inflection-0.5.1-r1.ebuild
index 8feea6f41aa1..794220dcbe5e 100644
--- a/dev-python/inflection/inflection-0.5.1-r1.ebuild
+++ b/dev-python/inflection/inflection-0.5.1-r1.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+
+inherit distutils-r1 pypi
DESCRIPTION="A port of Ruby on Rails' inflector to Python"
-HOMEPAGE="https://github.com/jpvanhal/inflection"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/jpvanhal/inflection/
+ https://pypi.org/project/inflection/
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
distutils_enable_sphinx docs
distutils_enable_tests pytest