summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/intelhex/intelhex-2.3.0-r1.ebuild')
-rw-r--r--dev-python/intelhex/intelhex-2.3.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/intelhex/intelhex-2.3.0-r1.ebuild b/dev-python/intelhex/intelhex-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..d55c12c0053b
--- /dev/null
+++ b/dev-python/intelhex/intelhex-2.3.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for Intel HEX files manipulations"
+HOMEPAGE="
+ https://github.com/python-intelhex/intelhex/
+ https://pypi.org/project/intelhex/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~riscv ~x86"
+
+distutils_enable_tests unittest