summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/iocapture/iocapture-0.1.2-r1.ebuild')
-rw-r--r--dev-python/iocapture/iocapture-0.1.2-r1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2-r1.ebuild b/dev-python/iocapture/iocapture-0.1.2-r1.ebuild
deleted file mode 100644
index fd39e0ddb932..000000000000
--- a/dev-python/iocapture/iocapture-0.1.2-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Capture stdout,stderr easily"
-HOMEPAGE="https://pypi.org/project/iocapture/"
-SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
-LICENSE="MIT"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
- ${RDEPEND}
- )"
-
-python_test() {
- py.test || die "Tests fail with ${EPYTHON}"
-}