summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/isort/isort-4.3.21_p2-r1.ebuild')
-rw-r--r--dev-python/isort/isort-4.3.21_p2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/isort/isort-4.3.21_p2-r1.ebuild b/dev-python/isort/isort-4.3.21_p2-r1.ebuild
new file mode 100644
index 000000000000..88bf1e9272a3
--- /dev/null
+++ b/dev-python/isort/isort-4.3.21_p2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PV="${PV//_p/-}"
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="https://github.com/timothycrosley/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pipfile[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ dev-python/futures[${PYTHON_USEDEP}]
+ ' -2)
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/isort-4.3.21_p1-tests.patch"
+)
+
+distutils_enable_tests pytest