summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itsdangerous/itsdangerous-1.1.0-r1.ebuild')
-rw-r--r--dev-python/itsdangerous/itsdangerous-1.1.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/itsdangerous/itsdangerous-1.1.0-r1.ebuild b/dev-python/itsdangerous/itsdangerous-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..5ef7c878bb5a
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-1.1.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="https://pythonhosted.org/itsdangerous/ https://pypi.org/project/itsdangerous/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest