summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-1.5.3-r1.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.5.3-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.5.3-r1.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.5.3-r1.ebuild
deleted file mode 100644
index 16373fd2e8e8..000000000000
--- a/dev-python/jaraco-collections/jaraco-collections-1.5.3-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Models and classes to supplement the stdlib collections module"
-HOMEPAGE="https://github.com/jaraco/jaraco.collections"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
-RDEPEND="
- <dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- dev-python/jaraco-classes[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${PDEPEND}
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}