summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-env')
-rw-r--r--dev-python/jaraco-env/Manifest1
-rw-r--r--dev-python/jaraco-env/jaraco-env-1.0.0.ebuild27
-rw-r--r--dev-python/jaraco-env/metadata.xml14
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jaraco-env/Manifest b/dev-python/jaraco-env/Manifest
new file mode 100644
index 000000000000..b05b5dbbb791
--- /dev/null
+++ b/dev-python/jaraco-env/Manifest
@@ -0,0 +1 @@
+DIST jaraco.env-1.0.0.tar.gz 6664 BLAKE2B c5559444d386fe34d6f639795f9adb68bc750452a7a3b2360971b07bc9876921466e6da9ff1f2d1891910c94891759de8550af0c4f9da311ae7443bfc7c3bdf1 SHA512 67879bd531bb1056bab0dfa47f92a7257e184b8db2a9bf3d588460070401e76e884cf3134ee4c01a6c517d48a0e111fec3a4759d305ee7608797816b27d33473
diff --git a/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild b/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
new file mode 100644
index 000000000000..0ffb98b5fc45
--- /dev/null
+++ b/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilities for environment variables"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.env/
+ https://pypi.org/project/jaraco.env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jaraco-env/metadata.xml b/dev-python/jaraco-env/metadata.xml
new file mode 100644
index 000000000000..493b35446cb9
--- /dev/null
+++ b/dev-python/jaraco-env/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jaraco.env</remote-id>
+ <remote-id type="github">jaraco/jaraco.env</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.env/issues</bugs-to>
+ </upstream>
+</pkgmetadata>