summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-packaging/jaraco-packaging-4.1.ebuild')
-rw-r--r--dev-python/jaraco-packaging/jaraco-packaging-4.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jaraco-packaging/jaraco-packaging-4.1.ebuild b/dev-python/jaraco-packaging/jaraco-packaging-4.1.ebuild
new file mode 100644
index 000000000000..1584db69651b
--- /dev/null
+++ b/dev-python/jaraco-packaging/jaraco-packaging-4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Tools to supplement packaging Python releases"
+HOMEPAGE="https://github.com/jaraco/jaraco.packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ # Skip one test which requires network access
+ PYTHONPATH=. py.test -v -k "not test_revived_distribution" \
+ || die "tests failed with ${EPYTHON}"
+}