summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest3
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.12.0.ebuild57
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.5.0.ebuild31
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.5.1.ebuild30
-rw-r--r--dev-python/jaraco-text/metadata.xml7
5 files changed, 59 insertions, 69 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index c67117845167..876b22720a95 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,2 +1 @@
-DIST jaraco.text-3.5.0.tar.gz 15453 BLAKE2B 53a3553f09a6c33734684477fe1228b159269a6a7e38aa8381af54f17162d1658be1f91157fd092544141bd086fdded32bec2fa0103c4c6978301cae3e199a04 SHA512 da566f1a6d8343d05c51ca3f4635212094ddbc84fe9b460dd7630030a9b5bb28c97ccb0de5928da50230a182985c7e5bce8903d4019ce5afb89067ad938dd152
-DIST jaraco.text-3.5.1.tar.gz 11579 BLAKE2B 22753a39b839b575796952e12adf69a10a876d45240c5461f72afddb14d58bbc8396565fb094b3c314ab6d9fbadd7008a7dd66e788f54f17189a48c54b980f1a SHA512 468a2338b82c4352dba0ab40fb774329f115010fdf3633adb860297dffc64c54fb006f85e4d89580923c1e9136168bcf9fd689e33eebee32cd70382bb402debf
+DIST jaraco.text-3.12.0.tar.gz 16329 BLAKE2B e1314b3121d5d75ac4a986a342c3290f5523bb45be8bf8e994ed87188712464e75a805498a7d846aea157aa8592fbca444842d1b70a21e0add49e89dfa743a7a SHA512 75068006c96dae3b8d21228f2ae21820939c68b1fb7e5db35bd0c1126a20399eb4d99c6bea15e88076599956c4b41104558cd32d860d8f4fd4e96aeeb22711c9
diff --git a/dev-python/jaraco-text/jaraco-text-3.12.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.12.0.ebuild
new file mode 100644
index 000000000000..4fc6f1b0833c
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.12.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+
+ # remove CLI tools, they have annoying deps, no entry points
+ # and since there are dashes in their names, they can't be imported
+ # anyway
+ rm jaraco/text/*-*.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}
diff --git a/dev-python/jaraco-text/jaraco-text-3.5.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.5.0.ebuild
deleted file mode 100644
index 97a99b07211c..000000000000
--- a/dev-python/jaraco-text/jaraco-text-3.5.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Text utilities used by other projects by developer jaraco"
-HOMEPAGE="https://github.com/jaraco/jaraco.text"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 x86"
-
-RDEPEND="
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-3.2" \
- ">=dev-python/rst-linker-1.9"
-distutils_enable_tests pytest
diff --git a/dev-python/jaraco-text/jaraco-text-3.5.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.5.1.ebuild
deleted file mode 100644
index 0c032b9a238f..000000000000
--- a/dev-python/jaraco-text/jaraco-text-3.5.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Text utilities used by other projects by developer jaraco"
-HOMEPAGE="https://github.com/jaraco/jaraco.text"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
-
-RDEPEND="
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-3.2" \
- ">=dev-python/rst-linker-1.9"
-distutils_enable_tests pytest
diff --git a/dev-python/jaraco-text/metadata.xml b/dev-python/jaraco-text/metadata.xml
index 4e38311d16fc..0ca273bb4c56 100644
--- a/dev-python/jaraco-text/metadata.xml
+++ b/dev-python/jaraco-text/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>sbraz@gentoo.org</email>
- <name>Louis Sautier</name>
- </maintainer>
<maintainer type="project">
<email>python@gentoo.org</email>
<name>Python</name>
@@ -14,6 +10,5 @@
<remote-id type="pypi">jaraco.text</remote-id>
<remote-id type="github">jaraco/jaraco.text</remote-id>
<bugs-to>https://github.com/jaraco/jaraco.text/issues</bugs-to>
- <changelog>https://github.com/jaraco/jaraco.text/blob/master/CHANGES.rst</changelog>
</upstream>
</pkgmetadata>