summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jc')
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.23.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index 44fe22730f6c..8476138626cb 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1 +1,2 @@
DIST jc-1.23.0.gh.tar.gz 12850876 BLAKE2B d0eb0bdca90115583409238eb8b4081bec92fa46b9c2054fc9d3637126bc3e21fa295c90d2f3910645b21d5f60b432461ebb6482bf8930a8b1c06deb3b2e027a SHA512 24d5675573e3050a3d6c9ba7bbe6be786a1f318eb7d8800ef160848163065b1fc961939ab1cae37a89407ecfd426c1aace3fef6f7985cc18e80e0d44b0fcb4be
+DIST jc-1.23.1.gh.tar.gz 12853550 BLAKE2B b10c3688025c35b4f71345756b6efd93af1e8abe2a343ca66e9f658d986f7ce60c04526d65a27286425f1f24c188de3e2ba923e4304a8e669139006db1d53766 SHA512 6f2936b6c42136909ff04233cbabbf0a5827552d83f29131c42cbc4de20a3b7fee2263a5cdec9c596d39fb3edc26dbc56863631e992d124c038c53490ba37ebf
diff --git a/dev-python/jc/jc-1.23.1.ebuild b/dev-python/jc/jc-1.23.1.ebuild
new file mode 100644
index 000000000000..90c6c8f3f7cb
--- /dev/null
+++ b/dev-python/jc/jc-1.23.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest