summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jc')
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.22.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index 2a9ba879b4a7..e86d1c378cd6 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1 +1,2 @@
DIST jc-1.22.4.gh.tar.gz 12751657 BLAKE2B 287cd33585ca0812ea25a5f09ab1c35e61e1f2d22bea11b202b85a00704077260d331cc8df15b6c2063771ac8f4f3111f8eb99036a3f18da34171081a26c5f46 SHA512 d35dd48af283707835bacf6ee3dfef46ccbf0bf1c37c6418bab3aca0274e12a9c5198de03fa3b3198661ab51d7bfe376fdd04092f06c481abc80f5c20388cb0c
+DIST jc-1.22.5.gh.tar.gz 12820323 BLAKE2B 2248ce17322b79f6902d595d1afa9a9afff64c153f08396de7b4441f5be0bda000188740a39435f7049e2a0d940e3fb5e6a53b4cca20c518b4522145b7447264 SHA512 72f4d0389ccc716ff61cb182ce26597a65ae1b1a449ad24078f5369b3b4c824ff27366d06456075ee55b24c5c91beb59f2dc8ec86f9b7db47728808e0647724b
diff --git a/dev-python/jc/jc-1.22.5.ebuild b/dev-python/jc/jc-1.22.5.ebuild
new file mode 100644
index 000000000000..e2948de60616
--- /dev/null
+++ b/dev-python/jc/jc-1.22.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest