summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jedi/jedi-0.9.0.ebuild')
-rw-r--r--dev-python/jedi/jedi-0.9.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/jedi/jedi-0.9.0.ebuild b/dev-python/jedi/jedi-0.9.0.ebuild
deleted file mode 100644
index 127061a9504d..000000000000
--- a/dev-python/jedi/jedi-0.9.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RESTRICT="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test -v -v test \
- || die "Tests failed under ${EPYTHON}"
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
- distutils-r1_python_install_all
-}