summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/js2py/js2py-0.70_p20210218.ebuild')
-rw-r--r--dev-python/js2py/js2py-0.70_p20210218.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/js2py/js2py-0.70_p20210218.ebuild b/dev-python/js2py/js2py-0.70_p20210218.ebuild
index 89897bdcda22..998dd3f8363e 100644
--- a/dev-python/js2py/js2py-0.70_p20210218.ebuild
+++ b/dev-python/js2py/js2py-0.70_p20210218.ebuild
@@ -36,9 +36,11 @@ python_test() {
pushd ./tests >/dev/null || die
# Tests require "node_failed.txt" file where the logs are kept
- [ -f ./node_failed.txt ] && rm ./node_failed.txt
- touch ./node_failed.txt || die
+ if [[ -f ./node_failed.txt ]]; then
+ rm ./node_failed.txt || die
+ fi
+ touch ./node_failed.txt || die
"${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
popd >/dev/null || die