summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/js2py')
-rw-r--r--dev-python/js2py/Manifest3
-rw-r--r--dev-python/js2py/js2py-0.70_p20210218.ebuild51
-rw-r--r--dev-python/js2py/js2py-0.74.ebuild (renamed from dev-python/js2py/js2py-0.71.ebuild)29
-rw-r--r--dev-python/js2py/metadata.xml23
4 files changed, 22 insertions, 84 deletions
diff --git a/dev-python/js2py/Manifest b/dev-python/js2py/Manifest
index 744b05d851d7..b697ae236583 100644
--- a/dev-python/js2py/Manifest
+++ b/dev-python/js2py/Manifest
@@ -1,2 +1 @@
-DIST Js2Py-0.70_p20210218.tar.gz 1969615 BLAKE2B 4702b2e771bfd2a5158a3539c33932335816c74f9dbd132679036aa2b7e53796764dd852e92d72a35ecc31efa34b849776c45d8c81e80f85f59308edf0996f00 SHA512 757c895bc0ba933020336a70473ec4455cb93c17040a39f17d645782011ea72273291448f3448ffd34658b48ada45b77facf3d326133f1c0d63e2e26e2cd7f30
-DIST Js2Py-0.71.tar.gz 1969618 BLAKE2B 293a830f4188e66927b23900e8c376bf1a4bfdfa8726e33aa5aa75dcdf735cde89ce463741c142fc7e487ae89c7c11421e459d2fdd09ba88edfe953e4e087e42 SHA512 75bae61619d4766117f3c163d36427f3019825ecb08b745aee7c3b6f2d33a4ea8507ca180b63c0a8e575a5f9491eb64d6963acbb912edc7b934a676b38814597
+DIST Js2Py-0.74.tar.gz 2504984 BLAKE2B 1e4f34ad94947118aeaf84ff438f9bec5b2a8ca3c722d907d3b8015acfcaafe1f229cfe401ae0f3d07c0f074ecf2f9ca3aeb94ef9c394b7ed6d90f1279c1ffa2 SHA512 cb2f42c2bec0c15dadc301ee0a7ac452cc8c4bba4669e95f1155863590d6d00781883b54d4dab755a0f66eb6e30990fedca732494b1f8b6c07dc29f5203a8c8c
diff --git a/dev-python/js2py/js2py-0.70_p20210218.ebuild b/dev-python/js2py/js2py-0.70_p20210218.ebuild
deleted file mode 100644
index 444e9561e4d7..000000000000
--- a/dev-python/js2py/js2py-0.70_p20210218.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_COMMIT="ea16b519a0f72e17416859a57890b8388fce6e39"
-
-MY_PN="Js2Py"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
-HOMEPAGE="
- http://piter.io/projects/js2py/
- https://github.com/PiotrDabkowski/Js2Py/
- https://pypi.org/project/Js2Py/
-"
-SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="test? ( ${RDEPEND} )"
-
-S="${WORKDIR}/${MY_PN}-${MY_COMMIT}"
-
-python_test() {
- pushd ./tests >/dev/null || die
-
- # Tests require "node_failed.txt" file where the logs are kept
- if [[ -f ./node_failed.txt ]]; then
- rm ./node_failed.txt || die
- fi
-
- touch ./node_failed.txt || die
- "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
-
- popd >/dev/null || die
-}
diff --git a/dev-python/js2py/js2py-0.71.ebuild b/dev-python/js2py/js2py-0.74.ebuild
index ce887d3f5ace..22032fcf8e3b 100644
--- a/dev-python/js2py/js2py-0.71.ebuild
+++ b/dev-python/js2py/js2py-0.74.ebuild
@@ -1,28 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-MY_COMMIT="5f665f60083a9796ec33861240ce31d6d2b844b6"
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="Js2Py"
+PYTHON_COMPAT=( python3_{9..11} )
-MY_PN="Js2Py"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
-HOMEPAGE="
- http://piter.io/projects/js2py/
+HOMEPAGE="http://piter.io/projects/js2py/
https://github.com/PiotrDabkowski/Js2Py/
- https://pypi.org/project/Js2Py/
-"
-SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+ https://pypi.org/project/Js2Py/"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
RDEPEND="
>=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
@@ -30,13 +25,11 @@ RDEPEND="
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
"
-S="${WORKDIR}/${MY_PN}-${MY_COMMIT}"
-
python_test() {
pushd ./tests >/dev/null || die
# Tests require "node_failed.txt" file where the logs are kept
- if [[ -f ./node_failed.txt ]]; then
+ if [[ -f ./node_failed.txt ]] ; then
rm ./node_failed.txt || die
fi
diff --git a/dev-python/js2py/metadata.xml b/dev-python/js2py/metadata.xml
index fd0b3b582843..b6c7bb1a358e 100644
--- a/dev-python/js2py/metadata.xml
+++ b/dev-python/js2py/metadata.xml
@@ -1,16 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>xgqt@riseup.net</email>
- <name>Maciej Barć</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="github">PiotrDabkowski/Js2Py</remote-id>
- <remote-id type="pypi">Js2Py</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PiotrDabkowski/Js2Py</remote-id>
+ <remote-id type="pypi">Js2Py</remote-id>
+ </upstream>
</pkgmetadata>