summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json-rpc/json-rpc-1.9.2.ebuild')
-rw-r--r--dev-python/json-rpc/json-rpc-1.9.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.9.2.ebuild b/dev-python/json-rpc/json-rpc-1.9.2.ebuild
new file mode 100644
index 000000000000..45e2d772905d
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die
+}