summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpatch/jsonpatch-1.21.ebuild')
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.21.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/jsonpatch/jsonpatch-1.21.ebuild b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
deleted file mode 100644
index a3c42315c2d4..000000000000
--- a/dev-python/jsonpatch/jsonpatch-1.21.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
-HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_test() {
- "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
- "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
-}