summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest2
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.1.ebuild19
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.4.ebuild23
3 files changed, 24 insertions, 20 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index 08780dc0bb47..316fa5dc2861 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1 +1 @@
-DIST jsonpointer-2.1.tar.gz 8190 BLAKE2B 5b9d0b0a27c6e2d133de67cf0ff9442e639a06011005f94cb425568fd3e5678b4832e9467720261fb85669e8b83eac73b1cfa8058adbd78d46339cdf8359561c SHA512 4eed8c7fa908ce3ca79884e98b1b0e818d24515f6b7b2067daa49ab6dbd989be4bc43f387e980773c9fc17bca89d2039750cb0df76675259050e3f48c16da3b6
+DIST jsonpointer-2.4.tar.gz 9254 BLAKE2B 423a4ef71cd1029fe2c473940794a041df4c3422b8292d80290be7f11ac0e6b123d3074cb6f66a3d860274bdf5b0cd0716d24c9ee50b65e06139375dc93c84ad SHA512 41cc0f8b525bec4b18801aeaec1b2432c5f6475dd3f2bc0fb363cf6ceaac5c64e7993c72130a40c64427218a1eac352e93464137fe17427b9f8a34ae09699f4e
diff --git a/dev-python/jsonpointer/jsonpointer-2.1.ebuild b/dev-python/jsonpointer/jsonpointer-2.1.ebuild
deleted file mode 100644
index f350c5a37eef..000000000000
--- a/dev-python/jsonpointer/jsonpointer-2.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
-HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-python_test() {
- "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/jsonpointer/jsonpointer-2.4.ebuild b/dev-python/jsonpointer/jsonpointer-2.4.ebuild
new file mode 100644
index 000000000000..633d2c32567a
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-pointer/
+ https://pypi.org/project/jsonpointer/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}