summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild
deleted file mode 100644
index da371501d210..000000000000
--- a/dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~mips x86"
-fi
-
-DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
-HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_test() {
- esetup.py test
-}