summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonschema-spec/jsonschema-spec-0.2.4.ebuild')
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.2.4.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.2.4.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.2.4.ebuild
deleted file mode 100644
index 81eeedc289a1..000000000000
--- a/dev-python/jsonschema-spec/jsonschema-spec-0.2.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="JSONSchema Spec with object-oriented paths"
-HOMEPAGE="
- https://pypi.org/project/jsonschema-spec/
- https://github.com/p1c2u/jsonschema-spec/
-"
-SRC_URI="
- https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pathable-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/referencing-0.28.1[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/responses[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- # remove random pins due to caret operator
- sed -i -e 's:\^:>=:' -e 's:,<[0-9.]*::' pyproject.toml || die
- distutils-r1_src_prepare
-}