summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.9.1.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index c91102e18fb4..55182cb82cf7 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,4 +1,3 @@
DIST jsonschema-4.10.2.tar.gz 285395 BLAKE2B 2e40fc5e8b93922c12110f1983f933a07455d9f5d1388fc2c1ee8f07e042f3840573553f709ab7f373c8f5be0651996ffd203696bd0ec1356e90163dad8f4eb4 SHA512 1328af7b4bc70ce43aec6e27b75c9ebe1c2745eceb3b794aeb41eb430362123f9b40dda26e90e62f23d5733ff4fd21407b05569603ee1e2a4941c2009e1855e7
DIST jsonschema-4.15.0.tar.gz 290458 BLAKE2B 5b43f5ceb6c02a82a9440dc0009123131d225e1aecd0ecb3e434f90f18192e5911916fba018ec1f636751bc019eef2840816d70cc53e7a84e82a149e66b99134 SHA512 8293b1dd7b16eb77b19ce89608384b3d97c1523ba080f38e6293390ba1b326d970721fdd6966623fc8a94b2b3357d1a68e1cc40b16eed037979fe6eb5684fa3f
DIST jsonschema-4.16.0.tar.gz 292399 BLAKE2B b1a78bc7dbc7cd10324638b57ebe4593afbdcbeb8d4b247aa127f41d5f6cce5e7970f5db1576e6a761357d8efe453ef514ae49f58b6624a05c4b7771daff3721 SHA512 c84abc992f410e9d558e2ce06c7172e9e2d298cff469baf8a23b1ea5b4777e6addfa757c5cc62b2e28e257721ee55e04bec0852e5f525adfa87392cbf712828f
-DIST jsonschema-4.9.1.tar.gz 281177 BLAKE2B 210308d140b39f5a5506a3561b8eaa211fbc9a0eb0576975125fa998bf9a507221b5ab75bd4d0f5bcd6d2e3b70a1a07ef4bcfb1d0b88b29a218b074b7d5649a1 SHA512 d63b927c183077d0fe6978536416523229be0ce3a393e6cbc12fd9229bfa45ba035fd721a7722042d7cb6bcf4c720485d7ff877aae93cd62c9c48b984e802267
diff --git a/dev-python/jsonschema/jsonschema-4.9.1.ebuild b/dev-python/jsonschema/jsonschema-4.9.1.ebuild
deleted file mode 100644
index 427f7ac5b4af..000000000000
--- a/dev-python/jsonschema/jsonschema-4.9.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="
- https://pypi.org/project/jsonschema/
- https://github.com/python-jsonschema/jsonschema/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
- dev-python/pkgutil_resolve_name[${PYTHON_USEDEP}]
- ' 3.8)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
-"
-
-# formatter deps
-RDEPEND+="
- dev-python/fqdn[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/isoduration[${PYTHON_USEDEP}]
- >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
- dev-python/rfc3339-validator[${PYTHON_USEDEP}]
- dev-python/rfc3986-validator[${PYTHON_USEDEP}]
- dev-python/rfc3987[${PYTHON_USEDEP}]
- dev-python/uri_template[${PYTHON_USEDEP}]
- >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires pip, does not make much sense for the users
- jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
- # wtf?
- jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
-)