summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/junit-xml')
-rw-r--r--dev-python/junit-xml/Manifest2
-rw-r--r--dev-python/junit-xml/junit-xml-1.9-r1.ebuild (renamed from dev-python/junit-xml/junit-xml-1.9.ebuild)25
2 files changed, 17 insertions, 10 deletions
diff --git a/dev-python/junit-xml/Manifest b/dev-python/junit-xml/Manifest
index 87a9856405ef..fd75afcdd8e7 100644
--- a/dev-python/junit-xml/Manifest
+++ b/dev-python/junit-xml/Manifest
@@ -1 +1 @@
-DIST junit-xml-1.9.tar.gz 11111 BLAKE2B e40914263421e7021d6bd697a03ae74b596d915479f24e8227d8b0b0bda51529df58f7aa54b27e981bb1df0aa36d7876f4f30fff8924188143bc4dd6b1d80b17 SHA512 73d5245f4a324485370e91d0d4d9a754133e0f90e5ad9ae7070bbb7aad29bee5fda4103548483358d536834c5fee9c8bd5fef79c4b66f905a2aeb0823ef02d22
+DIST python-junit-xml-19d3cc333d35dfd2d17d75c506336c15e5c6685a.gh.tar.gz 11111 BLAKE2B e40914263421e7021d6bd697a03ae74b596d915479f24e8227d8b0b0bda51529df58f7aa54b27e981bb1df0aa36d7876f4f30fff8924188143bc4dd6b1d80b17 SHA512 73d5245f4a324485370e91d0d4d9a754133e0f90e5ad9ae7070bbb7aad29bee5fda4103548483358d536834c5fee9c8bd5fef79c4b66f905a2aeb0823ef02d22
diff --git a/dev-python/junit-xml/junit-xml-1.9.ebuild b/dev-python/junit-xml/junit-xml-1.9-r1.ebuild
index 1105e65ff90e..017d20cc87c9 100644
--- a/dev-python/junit-xml/junit-xml-1.9.ebuild
+++ b/dev-python/junit-xml/junit-xml-1.9-r1.ebuild
@@ -1,28 +1,35 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
-PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
+EGIT_COMMIT="19d3cc333d35dfd2d17d75c506336c15e5c6685a"
+MY_P=python-junit-xml-${EGIT_COMMIT}
+
DESCRIPTION="Create JUnit XML test result documents"
HOMEPAGE="
+ https://github.com/kyrus/python-junit-xml/
https://pypi.org/project/junit-xml/
- https://github.com/kyrus/python-junit-xml"
+"
# upstream fails both at uploading to pypi and making tags
# https://github.com/kyrus/python-junit-xml/issues/69
# https://github.com/kyrus/python-junit-xml/issues/31
-EGIT_COMMIT="19d3cc333d35dfd2d17d75c506336c15e5c6685a"
SRC_URI="
https://github.com/kyrus/python-junit-xml/archive/${EGIT_COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S=${WORKDIR}/python-junit-xml-${EGIT_COMMIT}
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest