summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/files/jupyter_client-7.0.6-test-timeout.patch38
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.3.4.ebuild46
-rw-r--r--dev-python/jupyter_client/metadata.xml23
4 files changed, 0 insertions, 108 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
deleted file mode 100644
index 9f582e55af80..000000000000
--- a/dev-python/jupyter_client/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST jupyter_client-7.3.4.tar.gz 329871 BLAKE2B 34f4cc01ced39e30f81e0c7524ada9319f7bea6fb0f941dad85ac3f969de71b68bde22359a9d343df84432e320994a8c4c4aa9ebd390b841e4b18042ac6f0b14 SHA512 3bb1fd7c93e16c03db0c249810fe48428dc9c1fa24ae885a3d30b4ac2d2e980f48edc06c2c6065b3e8f91610bf5bc7500854986f55c18bd9f695f192aa470beb
diff --git a/dev-python/jupyter_client/files/jupyter_client-7.0.6-test-timeout.patch b/dev-python/jupyter_client/files/jupyter_client-7.0.6-test-timeout.patch
deleted file mode 100644
index 740677c13d00..000000000000
--- a/dev-python/jupyter_client/files/jupyter_client-7.0.6-test-timeout.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Avoid test timeouts on slower hosts like e.g. ia64 (guppy):
-```
-FAILED jupyter_client/tests/test_kernelmanager.py::TestParallel::test_start_sequence_kernels[tcp] - Failed: Timeout >30.0s
-FAILED jupyter_client/tests/test_kernelmanager.py::TestParallel::test_start_sequence_kernels[ipc] - Failed: Timeout >30.0s
-```
---- a/jupyter_client/tests/test_client.py
-+++ b/jupyter_client/tests/test_client.py
-@@ -13,7 +13,7 @@ from jupyter_client.kernelspec import KernelSpecManager
- from jupyter_client.kernelspec import NATIVE_KERNEL_NAME
- from jupyter_client.kernelspec import NoSuchKernel
-
--TIMEOUT = 30
-+TIMEOUT = 180
-
- pjoin = os.path.join
-
---- a/jupyter_client/tests/test_kernelmanager.py
-+++ b/jupyter_client/tests/test_kernelmanager.py
-@@ -24,7 +24,7 @@ from jupyter_client import KernelManager
-
- pjoin = os.path.join
-
--TIMEOUT = 30
-+TIMEOUT = 180
-
-
- @pytest.fixture(params=["tcp", "ipc"])
---- a/jupyter_client/tests/test_multikernelmanager.py
-+++ b/jupyter_client/tests/test_multikernelmanager.py
-@@ -22,7 +22,7 @@ from jupyter_client import KernelManager
- from jupyter_client.multikernelmanager import AsyncMultiKernelManager
- from jupyter_client.multikernelmanager import MultiKernelManager
-
--TIMEOUT = 30
-+TIMEOUT = 180
-
-
- class TestKernelManager(TestCase):
diff --git a/dev-python/jupyter_client/jupyter_client-7.3.4.ebuild b/dev-python/jupyter_client/jupyter_client-7.3.4.ebuild
deleted file mode 100644
index 4ee8e59fa00b..000000000000
--- a/dev-python/jupyter_client/jupyter_client-7.3.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/jupyter_client/
- https://pypi.org/project/jupyter-client/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/entrypoints[${PYTHON_USEDEP}]
- >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
- >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/ipykernel-6.5[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/jupyter_client/metadata.xml b/dev-python/jupyter_client/metadata.xml
deleted file mode 100644
index a41692a7eeae..000000000000
--- a/dev-python/jupyter_client/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
- Contains the reference implementation of the Jupyter protocol. It
- also provides client and kernel management APIs for working with
- kernels. It also provides the jupyter kernelspec entrypoint for
- installing kernelspecs for use with Jupyter frontends.
- </longdescription>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="github">jupyter/jupyter_client</remote-id>
- <remote-id type="pypi">jupyter-client</remote-id>
- </upstream>
-</pkgmetadata>