summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.3.1.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 2026c6ac4285..9f582e55af80 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1 @@
-DIST jupyter_client-7.3.1.tar.gz 328697 BLAKE2B 9bdca39d974c21e1674f58a7aaa51a6b96e4dc307f918aacc403146827df5ad7a867243dd2df95e717ab7ebd62367817e4f43cae562f47147b4271d72240600e SHA512 86a98288f1be5321b8495d78770501ca45fe3139a482ec41606253eef69eaf4d3f284d1c373d9df64efe28428f32cd1a3b19842a7331b3ac200d780e7a786407
DIST jupyter_client-7.3.4.tar.gz 329871 BLAKE2B 34f4cc01ced39e30f81e0c7524ada9319f7bea6fb0f941dad85ac3f969de71b68bde22359a9d343df84432e320994a8c4c4aa9ebd390b841e4b18042ac6f0b14 SHA512 3bb1fd7c93e16c03db0c249810fe48428dc9c1fa24ae885a3d30b4ac2d2e980f48edc06c2c6065b3e8f91610bf5bc7500854986f55c18bd9f695f192aa470beb
diff --git a/dev-python/jupyter_client/jupyter_client-7.3.1.ebuild b/dev-python/jupyter_client/jupyter_client-7.3.1.ebuild
deleted file mode 100644
index a35f732a5e43..000000000000
--- a/dev-python/jupyter_client/jupyter_client-7.3.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/entrypoints[${PYTHON_USEDEP}]
- >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
- >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/ipykernel-6.5[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # relax pyzmq dep
- sed -i -e '/pyzmq/s:>=.*::' requirements.txt || die
- distutils-r1_src_prepare
-}