summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jwcrypto/jwcrypto-1.2.0.ebuild')
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.2.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/jwcrypto/jwcrypto-1.2.0.ebuild b/dev-python/jwcrypto/jwcrypto-1.2.0.ebuild
deleted file mode 100644
index 07a3309be78f..000000000000
--- a/dev-python/jwcrypto/jwcrypto-1.2.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
-HOMEPAGE="
- https://github.com/latchset/jwcrypto/
- https://pypi.org/project/jwcrypto/
-"
-SRC_URI="
- https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
- dev-python/deprecated[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Do not install doc in non-standard paths
- sed -i "/data_files/d" setup.py || die
- distutils-r1_python_prepare_all
-}