summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kafka-python')
-rw-r--r--dev-python/kafka-python/Manifest1
-rw-r--r--dev-python/kafka-python/kafka-python-2.0.2.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/kafka-python/Manifest b/dev-python/kafka-python/Manifest
index 3ce259cfeaab..036ad2744e38 100644
--- a/dev-python/kafka-python/Manifest
+++ b/dev-python/kafka-python/Manifest
@@ -1,2 +1 @@
DIST kafka-python-2.0.2.gh.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
-DIST kafka-python-2.0.2.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
diff --git a/dev-python/kafka-python/kafka-python-2.0.2.ebuild b/dev-python/kafka-python/kafka-python-2.0.2.ebuild
deleted file mode 100644
index e66e23a38729..000000000000
--- a/dev-python/kafka-python/kafka-python-2.0.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Kafka protocol support in Python"
-HOMEPAGE="https://github.com/dpkp/kafka-python/ https://pypi.org/project/kafka-python/"
-SRC_URI="https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/xxhash[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/lz4[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/zstandard[${PYTHON_USEDEP}]
- dev-python/python-snappy[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # Needs the unpackaged crc32c module
- test/record/test_util.py::test_crc32c[None]
- # Needs kafka server running
- test/test_consumer_integration.py::test_kafka_consumer_offsets_for_time_old
- )
- epytest ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- optfeature "LZ4 compression/decompression support" dev-python/lz4
- optfeature "Snappy compression support" dev-python/python-snappy
- optfeature "ZSTD compression/decompression support" dev-python/zstandard
-}