summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kazoo/kazoo-2.6.1.ebuild')
-rw-r--r--dev-python/kazoo/kazoo-2.6.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/kazoo/kazoo-2.6.1.ebuild b/dev-python/kazoo/kazoo-2.6.1.ebuild
deleted file mode 100644
index 948c64c25bdf..000000000000
--- a/dev-python/kazoo/kazoo-2.6.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 python3_8 )
-
-inherit distutils-r1
-
-DESCRIPTION="A high-level Python library that makes it easier to use Apache Zookeeper"
-HOMEPAGE="https://kazoo.readthedocs.org/ https://github.com/python-zk/kazoo/ https://pypi.org/project/kazoo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/graphviz[${PYTHON_USEDEP}]
- >=dev-python/objgraph-3.4.0[${PYTHON_USEDEP}]
- )
-"
-
-# requires zookeeper running to test
-RESTRICT="test"
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html docs docs/_build/html || die
- fi
-}
-
-python_test() {
- ZOOKEEPER_VERSION="2.6.1" esetup.py test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- local DOCS=( {CHANGES,CONTRIBUTING,README}.md )
- distutils-r1_python_install_all
-}