summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-23.0.1.ebuild')
-rw-r--r--dev-python/keyring/keyring-23.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/keyring/keyring-23.0.1.ebuild b/dev-python/keyring/keyring-23.0.1.ebuild
index d91059c922cf..f1b73ebf00eb 100644
--- a/dev-python/keyring/keyring-23.0.1.ebuild
+++ b/dev-python/keyring/keyring-23.0.1.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Provides access to the system keyring service"
@@ -35,5 +33,10 @@ distutils_enable_sphinx docs \
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
python_test() {
- epytest --ignore tests/backends/test_kwallet.py
+ local deselect=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+ )
+ epytest --ignore tests/backends/test_kwallet.py ${deselect[@]/#/--deselect }
}