summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keystoneauth')
-rw-r--r--dev-python/keystoneauth/Manifest1
-rw-r--r--dev-python/keystoneauth/keystoneauth-3.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/Manifest b/dev-python/keystoneauth/Manifest
index 5a3ce513131f..5bd6870f65bd 100644
--- a/dev-python/keystoneauth/Manifest
+++ b/dev-python/keystoneauth/Manifest
@@ -4,3 +4,4 @@ DIST keystoneauth1-2.20.0.tar.gz 187746 BLAKE2B c47608115ce31bac39d7f410c9153feb
DIST keystoneauth1-2.4.1.tar.gz 150586 BLAKE2B 78d3b5c99bf1d11573a7aba317aca669caee9b5a843eb7d25e3a51e315398617530c5beb9e067500d06922024cb9b5705cff1e9c9f25328e68d0e8155df26971 SHA512 f9e8fcea7b23001b907d643d5bf67fc4779c8729cca213b3240ef988eda9de1212b15c2031f6fd8b431aafac85e773346eda71e0b414fe967728611b6817fb05
DIST keystoneauth1-2.4.2.tar.gz 151213 BLAKE2B aacdee83231982e919925aef9d305d517a00a4db323d407176296d8349d5afe01229429a00949ee2fc6adb49f655de840c90c1ab7d8b5dc5420a67f869522241 SHA512 dd3b0907c554606489081b970ad248efe52aa6593cb8584ac1d4e3b05075b6a60b8c5f159c00f5668eb0938dbed655e7135ac9b7d3d6017f2f280f69b9080122
DIST keystoneauth1-3.1.0.tar.gz 217744 BLAKE2B 4e07c7f4dd6fc097c6838b2a18105656b16f8e45dd553d2908c55fa7aeb5c8dcd2968ca0c3954be0b66044880eec7c33fd9c42413a1ae6c93258a902666bb896 SHA512 3214e08cf449a0eff35eff0400542cbb9e46051095d7955593fec89c4ba31062677f434c70c40037db213fa0e0db15c66d1058e0eca35b1d214967f7fa3fcf14
+DIST keystoneauth1-3.4.0.tar.gz 227170 BLAKE2B 57f28ce5a36362f34fcfb2f456a19332df6851a4d372fe890286b4d48469ff69a3ad7281b55d4aa338f61d437f5e07908fc55210e2085a6d9a974cf0bf451c81 SHA512 aeaefb0e5b369e36e06adc1bada104dab2c2aed22bf96cc3e20a5dd4ce8ae10869eb73ce4802faef70f191c3bbd38e3b5c3dff3606c46956fb350c0875cb7a7d
diff --git a/dev-python/keystoneauth/keystoneauth-3.4.0.ebuild b/dev-python/keystoneauth/keystoneauth-3.4.0.ebuild
new file mode 100644
index 000000000000..e636a0e9f388
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-3.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"