summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyutils/keyutils-0.6-r1.ebuild')
-rw-r--r--dev-python/keyutils/keyutils-0.6-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/keyutils/keyutils-0.6-r1.ebuild b/dev-python/keyutils/keyutils-0.6-r1.ebuild
deleted file mode 100644
index 9023760c6de2..000000000000
--- a/dev-python/keyutils/keyutils-0.6-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="A set of python bindings for keyutils"
-HOMEPAGE="https://github.com/sassoftware/python-keyutils/"
-SRC_URI="https://github.com/sassoftware/python-keyutils/archive/refs/tags/${PV}.tar.gz -> python-keyutils-${PV}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-DEPEND="sys-apps/keyutils"
-RDEPEND="${DEPEND}"
-
-distutils_enable_tests pytest
-
-S="${WORKDIR}/python-keyutils-${PV}"
-
-src_prepare() {
- default
- sed -i -e '/pytest-runner/d' setup.py || die
- rm keyutils/_keyutils.c || die
-}
-
-python_test() {
- ln -s "${S}"/test "${BUILD_DIR}"/test || die
- cd "${BUILD_DIR}" || die
- distutils-r1_python_test
-}