summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kiwisolver/kiwisolver-1.3.0.ebuild')
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/kiwisolver-1.3.0.ebuild b/dev-python/kiwisolver/kiwisolver-1.3.0.ebuild
new file mode 100644
index 000000000000..2d2ec37813ab
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/kiwi-${PV}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest