summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest3
-rw-r--r--dev-python/kombu/kombu-5.0.1.ebuild82
-rw-r--r--dev-python/kombu/kombu-5.3.6.ebuild83
-rw-r--r--dev-python/kombu/kombu-5.3.7.ebuild83
-rw-r--r--dev-python/kombu/metadata.xml9
5 files changed, 169 insertions, 91 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index b767a8f4c937..0e15fc06f026 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1 +1,2 @@
-DIST kombu-5.0.1.tar.gz 404428 BLAKE2B 89d4c2daf70c3dcd0a990c8f045074780f2d4f13f39899c0ab3b73b473948469746cf8872aaa8565f5c4b071bf18ff510cd565e8f9b6a3735a0bf1d0af55e9b6 SHA512 aa5d35b7753f5ec8d95512c322fabf0163628b9afbd228faa2be910a1cd4ea3236a7e43485e17650e1aa9aebae59a91a2b0bdc1950e4e4c622b499a4ae29ea0e
+DIST kombu-5.3.6.tar.gz 439311 BLAKE2B 6be4f7b1459f9f48ba933075871a8f34c3817b5a7fa31875f4370b88abc8271a86ff628e94cbe5a1474f9fa01b99ecd98dfa6ada8dfcfaa26e518d15e83e1b6e SHA512 22712b3f105a87790103e8df3565d9bfa30bfadc706d7f8d8dc7eb908575603b8f3f596cc04b428bd69ff63b484509aadf0f031a792e315883d3dc878705a79e
+DIST kombu-5.3.7.tar.gz 439344 BLAKE2B 9443cb7d9d03ca7ed49b1e2c5a413e5d5633ccaf8cb2b8545b4bd0a7a7699f7fc773f735e6b26abf582502f1dbf11b088c612d749f09cab99950e145e8ee82e0 SHA512 48104d61a7c38a211ec378f90aade09d682a99d4f8b3d18b4bce49b51c80be794ab4b012d2974893fbc630a37c52dad10fb57f8335238b3002a64e025a148ee2
diff --git a/dev-python/kombu/kombu-5.0.1.ebuild b/dev-python/kombu/kombu-5.0.1.ebuild
deleted file mode 100644
index 189ab9bc017a..000000000000
--- a/dev-python/kombu/kombu-5.0.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="AMQP Messaging Framework for Python"
-HOMEPAGE="https://pypi.org/project/kombu/ https://github.com/celery/kombu"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples mongodb msgpack redis sqs test yaml"
-RESTRICT="!test? ( test )"
-
-# zookeeper backend support possible via dev-python/kazoo
-RDEPEND="
- >=dev-python/importlib_metadata-0.18[${PYTHON_USEDEP}]
- >=dev-python/py-amqp-2.6.0[${PYTHON_USEDEP}]
- <dev-python/py-amqp-2.7[${PYTHON_USEDEP}]
- >=dev-python/pyro-4.76:4[${PYTHON_USEDEP}]
- sqs? ( >=dev-python/boto3-1.4.4[${PYTHON_USEDEP}] )
- msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )
- mongodb? ( >=dev-python/pymongo-3.3.0[${PYTHON_USEDEP}] )
- redis? ( >=dev-python/redis-py-3.3.11[${PYTHON_USEDEP}] )
- yaml? ( >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )"
-# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-20.6.7[${PYTHON_USEDEP}]
- test? (
- >=dev-python/case-1.5.2[${PYTHON_USEDEP}]
- <=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinx_celery-1.1[${PYTHON_USEDEP}]
- )"
-
-# kazoo is optional for tests.
-# Refrain for now, no established demand for it from users
-
-# Req'd for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
-)
-
-python_prepare_all() {
- # AttributeError: test_Etcd instance has no attribute 'patch'
- rm t/unit/transport/test_etcd.py || die
- # allow use of new (renamed) msgpack
- sed -i '/msgpack/d' requirements/extras/msgpack.txt || die
- # pytest-sugar is not packaged
- sed -i '/pytest-sugar/d' requirements/test.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # Doc build misses and skips only content re librabbitmq which is not in portage
- if use doc; then
- emake -C docs html
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/kombu/kombu-5.3.6.ebuild b/dev-python/kombu/kombu-5.3.6.ebuild
new file mode 100644
index 000000000000..1dc983b25728
--- /dev/null
+++ b/dev-python/kombu/kombu-5.3.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="
+ https://github.com/celery/kombu/
+ https://pypi.org/project/kombu/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/amqp-5.1.1[${PYTHON_USEDEP}]
+ <dev-python/amqp-6.0.0[${PYTHON_USEDEP}]
+ dev-python/vine[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.22.2[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.2[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-celery
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ t/unit/transport/test_redis.py::test_Channel::test_connparams_health_check_interval_supported
+ )
+ local EPYTEST_IGNORE=(
+ # obsolete Pyro4
+ t/unit/transport/test_pyro.py
+ # unpackaged azure
+ t/unit/transport/test_azurestoragequeues.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Amazon SQS backend" "dev-python/boto3 dev-python/pycurl"
+ optfeature "Etcd backend" dev-python/python-etcd
+ optfeature "MongoDB backend" dev-python/pymongo
+ optfeature "Redis backend" dev-python/redis
+ optfeature "sqlalchemy backend" dev-python/sqlalchemy
+ optfeature "yaml backend" dev-python/pyyaml
+ optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
+ optfeature "brotli compression" "app-arch/brotli[python]"
+ optfeature "zstd compression" dev-python/zstandard
+}
diff --git a/dev-python/kombu/kombu-5.3.7.ebuild b/dev-python/kombu/kombu-5.3.7.ebuild
new file mode 100644
index 000000000000..a293597a7827
--- /dev/null
+++ b/dev-python/kombu/kombu-5.3.7.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="
+ https://github.com/celery/kombu/
+ https://pypi.org/project/kombu/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/amqp-5.1.1[${PYTHON_USEDEP}]
+ <dev-python/amqp-6.0.0[${PYTHON_USEDEP}]
+ dev-python/vine[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.22.2[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.2[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-celery
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ t/unit/transport/test_redis.py::test_Channel::test_connparams_health_check_interval_supported
+ )
+ local EPYTEST_IGNORE=(
+ # obsolete Pyro4
+ t/unit/transport/test_pyro.py
+ # unpackaged azure
+ t/unit/transport/test_azurestoragequeues.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Amazon SQS backend" "dev-python/boto3 dev-python/pycurl"
+ optfeature "Etcd backend" dev-python/python-etcd
+ optfeature "MongoDB backend" dev-python/pymongo
+ optfeature "Redis backend" dev-python/redis
+ optfeature "sqlalchemy backend" dev-python/sqlalchemy
+ optfeature "yaml backend" dev-python/pyyaml
+ optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
+ optfeature "brotli compression" "app-arch/brotli[python]"
+ optfeature "zstd compression" dev-python/zstandard
+}
diff --git a/dev-python/kombu/metadata.xml b/dev-python/kombu/metadata.xml
index 4a0992c7fa88..659be9f1d87e 100644
--- a/dev-python/kombu/metadata.xml
+++ b/dev-python/kombu/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
@@ -10,11 +10,4 @@
<remote-id type="pypi">kombu</remote-id>
<remote-id type="github">celery/kombu</remote-id>
</upstream>
- <use>
- <flag name="sqs">Enables Amazon SQS transport module for Kombu</flag>
- <flag name="mongodb">Enables MongoDB backend</flag>
- <flag name="msgpack">Enables MessagePack (de)serializer for Python</flag>
- <flag name="redis">Enables Redis backend</flag>
- <flag name="yaml">Enables yaml backend</flag>
- </use>
</pkgmetadata>