summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lark')
-rw-r--r--dev-python/lark/Manifest2
-rw-r--r--dev-python/lark/lark-1.1.5.ebuild44
-rw-r--r--dev-python/lark/lark-1.1.6.ebuild44
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/lark/Manifest b/dev-python/lark/Manifest
index 60d4d838d418..2a88b04f22b8 100644
--- a/dev-python/lark/Manifest
+++ b/dev-python/lark/Manifest
@@ -1,3 +1 @@
-DIST lark-1.1.5.tar.gz 246737 BLAKE2B 2111bb6c2f6eaa05b803daf11f0f55641c9b3943a97f943fd27b5dd33f8b511e3b0fc4fb335edbb3926ad19da6cb2696b7f87003b7def068cae1d805b3feb8d9 SHA512 8103e050745c83c99b077667aa8b1d4dfad28f5554d2381534b3518d8d3e8adb70f0304fdc7e1c762d3ea26089181d9632dea155b6cd97237078b89330a6711e
-DIST lark-1.1.6.tar.gz 251270 BLAKE2B 2f2b81eef82ba2cb774e3aab448a092256a714e7118da08e1e25297c1573d0b833231e6b6158dc88fb19c80af370b1e72946dc929f6379408a9aea6c596f3605 SHA512 347ba7423f15fe38c97446991b4d2d0d6edd50bc656aa9a67c8b6d94b8cdbf2b006f3391c6c06fe000fc4b2657480e6a66a9580ebb0440eeef2b5a6a5418567b
DIST lark-1.1.7.tar.gz 251290 BLAKE2B c6f19eadf29c75257e0b49231e621bffd27ff6c569a07159e9f4934d0bf74abb6df9425fdd971392b415fc19d12421abc67186d844f2ef1c294205a25f4e263a SHA512 59e5567ebff173a25caa2ea4db3ff3f284bd580ce68a6a3ca27ceff34158a9b56fc404ebf3016e2bbb074fd19286a0d511ffaadf2f157185f45b10305c3c8474
diff --git a/dev-python/lark/lark-1.1.5.ebuild b/dev-python/lark/lark-1.1.5.ebuild
deleted file mode 100644
index ebc8caa6fd91..000000000000
--- a/dev-python/lark/lark-1.1.5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
-HOMEPAGE="
- https://github.com/lark-parser/lark/
- https://pypi.org/project/lark/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-BDEPEND="
- test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # require dev-python/js2py which is a really bad quality package
- tests/test_nearley/test_nearley.py
- )
-
- if has "${EPYTHON}" pypy3 python3.{8,9}; then
- EPYTEST_IGNORE+=(
- # test using Python 3.10+ syntax
- tests/test_pattern_matching.py
- )
- fi
-
- epytest
-}
diff --git a/dev-python/lark/lark-1.1.6.ebuild b/dev-python/lark/lark-1.1.6.ebuild
deleted file mode 100644
index f65a5584bcd8..000000000000
--- a/dev-python/lark/lark-1.1.6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
-HOMEPAGE="
- https://github.com/lark-parser/lark/
- https://pypi.org/project/lark/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
-
-BDEPEND="
- test? (
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # require dev-python/js2py which is a really bad quality package
- tests/test_nearley/test_nearley.py
- )
-
- if has "${EPYTHON}" pypy3 python3.{8,9}; then
- EPYTEST_IGNORE+=(
- # test using Python 3.10+ syntax
- tests/test_pattern_matching.py
- )
- fi
-
- epytest
-}