summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/liblarch')
-rw-r--r--dev-python/liblarch/Manifest2
-rw-r--r--dev-python/liblarch/liblarch-2.1.0.ebuild27
-rw-r--r--dev-python/liblarch/liblarch-3.0.ebuild31
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/liblarch/Manifest b/dev-python/liblarch/Manifest
index 65a7a89c6aca..14cc8490bc5e 100644
--- a/dev-python/liblarch/Manifest
+++ b/dev-python/liblarch/Manifest
@@ -1,3 +1 @@
-DIST liblarch-2.1.0.tar.gz 26829 BLAKE2B 14bf85bb91d800e5ca0d8eb4da6c2d9b3979b4560280776c276cad9cbd026331768729e5b4ca9b4646c6b199566cfb5a42b5148ef089e0ae5ec7e45d09090ba5 SHA512 fd6a6c48142e434f49fb49d9dee874b88f013775c280dd2dc929ed5fff4df7bd3743bf915b09dac4329f894cac24e466d78366a072136de389725bc5ed985ec1
DIST liblarch-3.0.1.tar.gz 55564 BLAKE2B bb3b3b67f9a64403e1a57e9b47217aa1a9b066708d70e1387a8b864a81dbdc4202b6b75012365f9c93179bbfcc4304116a33ebd3bd892f24334e0c200ae94b56 SHA512 591854eae54f5e644882f8ba486434f85196115a3c06f249cf7b343bb0e029b78a818610881d9d656f6342748c956cf5a213a22843e95b2ed05246a8013ff8ca
-DIST liblarch-3.0.tar.gz 55785 BLAKE2B 1d69882b8748e7b3a1b0af6ef66f5a32e04e3b742d10ba3971fc5c0f490ca692584d46a849cc2e6d3654ab577f7698619540b54f9a13a7b0d5079b34fee248f7 SHA512 bf50880402ae8b490c5d98b158c5123d00340d981b26a5dec4538f1f4a1008efd5cfe024251728f90f1ebaade4ee18601fa30432d64921c3986b53efc531c68a
diff --git a/dev-python/liblarch/liblarch-2.1.0.ebuild b/dev-python/liblarch/liblarch-2.1.0.ebuild
deleted file mode 100644
index 2bba1e2d90f7..000000000000
--- a/dev-python/liblarch/liblarch-2.1.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library to handle directed acyclic graphs"
-HOMEPAGE="https://live.gnome.org/liblarch"
-SRC_URI="http://gtg.fritalk.com/publique/gtg.fritalk.com/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-# This is what should be run if tarball included testsuite
-#python_test() {
-# ${PYTHON} "${S}"/run-tests
-#}
diff --git a/dev-python/liblarch/liblarch-3.0.ebuild b/dev-python/liblarch/liblarch-3.0.ebuild
deleted file mode 100644
index e0cb347435d9..000000000000
--- a/dev-python/liblarch/liblarch-3.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Library to handle directed acyclic graphs"
-HOMEPAGE="https://wiki.gnome.org/Projects/liblarch"
-SRC_URI="https://github.com/getting-things-gnome/liblarch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- virtx nosetests -v || die "Tests fail with ${EPYTHON}"
-}