summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libnacl/libnacl-1.7.1.ebuild')
-rw-r--r--dev-python/libnacl/libnacl-1.7.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/libnacl/libnacl-1.7.1.ebuild b/dev-python/libnacl/libnacl-1.7.1.ebuild
new file mode 100644
index 000000000000..4021fa51ab35
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{6..9})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="https://github.com/saltstack/libnacl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libsodium"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/libnacl-1.7.1-py39.patch"
+)
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v -p 'test_*.py' tests/ || die "Tests failed with ${EPYTHON}"
+}