summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lmfit/lmfit-1.0.1-r1.ebuild')
-rw-r--r--dev-python/lmfit/lmfit-1.0.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/lmfit/lmfit-1.0.1-r1.ebuild b/dev-python/lmfit/lmfit-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..e3d9bc9fd9c6
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..8} )
+inherit distutils-r1
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ >=dev-python/asteval-0.9.16[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2[${PYTHON_USEDEP}]
+"
+RDEPEND="${BDEPEND}"
+
+distutils_enable_tests pytest