summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lmfit/lmfit-1.2.1.ebuild')
-rw-r--r--dev-python/lmfit/lmfit-1.2.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/lmfit/lmfit-1.2.1.ebuild b/dev-python/lmfit/lmfit-1.2.1.ebuild
deleted file mode 100644
index e4083a2df21c..000000000000
--- a/dev-python/lmfit/lmfit-1.2.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
-HOMEPAGE="
- https://lmfit.github.io/lmfit-py/
- https://github.com/lmfit/lmfit-py/
- https://pypi.org/project/lmfit/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/asteval-0.9.28[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.6[${PYTHON_USEDEP}]
- >=dev-python/uncertainties-3.1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -o addopts=
-}