summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/logilab-constraint')
-rw-r--r--dev-python/logilab-constraint/logilab-constraint-0.5.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/logilab-constraint/logilab-constraint-0.5.0-r2.ebuild b/dev-python/logilab-constraint/logilab-constraint-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..4ce61777e8a1
--- /dev/null
+++ b/dev-python/logilab-constraint/logilab-constraint-0.5.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A finite domain constraints solver written in 100% pure Python"
+HOMEPAGE="http://www.logilab.org/project/logilab-constraint"
+SRC_URI="ftp://ftp.logilab.org/pub/constraint/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/logilab-common-1.2.2-r1[${PYTHON_USEDEP}]"
+
+DOCS=( doc/CONTRIBUTORS )
+
+python_install() {
+ # Avoid collisions with dev-python/logilab-common.
+ distutils-r1_python_install
+ rm -f "${D}$(python_get_sitedir)/logilab/__init__.py" || die
+}
+
+python_install_all() {
+ use doc && dohtml doc/documentation.html
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}